
Example name  Caffeine by subgroups 
 
Effect size  Risk ratio 
Analysis type  Subgroups analysis, Meta-Regression 
Level   Intermediate 
 
 
Synopsis 
 
This analysis includes 25 studies where patients were randomized to receive either analgesic alone or 
analgesic plus caffeine.  Outcome was the proportion of patients who reported a “good” level of pain 
relief. The effect size was the risk ratio. 
 
For the 25 studies there was clear evidence that patients treated with caffeine were about 10% more 
likely to report success as compared with the control group.  However, there was substantial dispersion 
in the effect size.  The true effect size probably ranges from a risk ratio of 1.02 to 1.22.  We ran 
additional analyses to see if this variation could be explained by various factors. 
 
We used subgroup analyses to compare the effect size in studies – 
 

• That employed a low dose, moderate dose, or high dose of caffeine 
• Where the basic analgesic was Ibuprofen vs. studies where it was Paracetamol 
• Where the pain was from headache vs. studies where the pain was from surgery   

 
We use this example to show 
 

• How to enter data from 2x2 tables 
• How to perform a basic analysis 
• How to interpret statistics for heterogeneity 
• How to estimate the dispersion in true effects 
• How to compare the effect size in different subgroups using subgroup analysis 
• How to compare the effect size in different subgroups using meta-regression 

 

To open a CMA file > Download and Save file | Start CMA | Open file from within CMA 

Download CMA file for computers that use a period to indicate decimals  
Download CMA file for computers that use a comma to indicate decimals  
 
Download this PDF 
Download data in Excel 
Download trial of CMA  
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Start the program 

• Select the option [Start a blank spreadsheet] 
• Click [Ok] 
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Click Insert > Column for > Study names 

 

The screen should look like this 

 

Click Insert > Column for > Effect size data 
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The program displays this wizard   
   
Select [Show all 100 formats] 
Click [Next] 
 

 

 
   
Select [Comparison of two groups…] 
Click [Next] 
 

 

 
   
Drill down to 
 
Dichotomous (number of events) 
Unmatched groups, prospective … 
Events and sample size in each group 
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The program displays this wizard 

Enter the following labels into the wizard 

• First group > Caffeine 
• Second group > Control 
• Name for events > Relief 
• Name for non-events > Pain 

Click [Ok] and the program will copy the names into the grid  
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We need to add a column for the moderator, Dose 

Click Insert > Column for > Moderator variable 

 

• Name the moderator > Dose 
• Set the data type to Categorical 
• Click Ok 
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• Insert a column for > Moderator > Categorical with the name Analgesic.  This will be used to 
code the type of medication (e.g. ibuprofen) 
 

• Insert a column for > Moderator > Categorical with the name Pain Type.  This will be used to 
code the type of pain (e.g. post-surgical) 

The screen should look like this 
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There are three options at this point 

• Enter the data directly into CMA  
• – or – Open the CMA data file “Caffeine.cma” 
• – or – Copy the data from Excel“Caffeine.xls” 

Here, we’ll show how to copy the data from Excel 

• Switch to Excel and open the file  
• Highlight the rows and columns as shown (Columns A to E only), and press CTRL-C to copy to 

clipboard 
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• Switch to CMA 
• Click in cell Study-name 1 

 

 

• Press [CTRL-V] to paste the data 
• The screen should look like this 

 

  

Click here 
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• Switch to Excel 
• Highlight the columns for Dose, Analgesic, and Pain Type as shown and click [CTRL-C] 
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• Switch to CMA 
• Click the cell Dose – 1 
• Press CTRL-V to paste the data 

 

  

Click here 
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At this point we should check that the data has been copied correctly 

 

• Click anywhere in Row 1 
• Select Edit > Delete row, and confirm 

 

  

Click here 
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The screen should look like this 
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By default, the program is displaying the odds ratio as the effect size 

We want to switch to the risk ratio 

 

• Right-click on any of the yellow columns 
• Click Customize computed effect size display 
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• Tick Risk ratio 
• Tick Log risk ratio 
• Select Risk ratio in the drop-down box in the wizard 
• De-select Odds ratio 
• De-select log odds ratio 
• Click Ok 

The program now display the risk ratio rather than the odds ratio 
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Click File > Save As and save the file 

 

Note that the file name is now in the header.   

• [Save] will over-write the prior version of this file without warning 
• [Save As…] will allow you to save the file with a new name 
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By convention we’ve put the treated group (caffeine plus analgesic) in the first two columns and the 
control (analgesic alone) in the second two columns.  Also by convention, we’ve defined “Event” as the 
presence of the outcome (relief).   
 
When we follow these conventions, and if the treated group does better than the control, then  
 

• If the “event” is a bad outcome (such as relapse), the risk ratio will be less than 1. 
• If the “event” is a good outcome (such as relief), the risk ratio will be greater than 1. 

 
Therefore, in the present case, a risk ratio greater than 1 indicates that patients treated with caffeine 
were more likely to get relief. 
 
It’s always a good idea to check at least one study and make sure that we have the direction right.  For 
this purpose we’ll use the last study (McQauy), where the risk ratio is very high, and the distinction 
between groups should be clear. 
 

 
 
For the caffeine group, more than half the patients (12/29) improved.  For the control group, less than 
10% (2/31) improved. Clearly, the treated group did better, and the risk ratio (6.414) is greater than one.  
This tells us that we are interpreting the direction of the effect size properly. 
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• To run the analysis, click [Run analysis] 
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This is the basic analysis screen 

Initially, the program displays the fixed-effect analysis.  This is indicated by the tab at the bottom and 
the label in the plot. 

 

Virtually all studies have risk ratios over 1.0, which means that the caffeine group (analgesic plus 
caffeine) did better than the control (analgesic alone), but the effect is statistically significant in only a 
few of the studies. 
 
The effects seem to be reasonably consistent.  Aside from three exceptions, all of the studies have effect 
sizes that line up in a fairly narrow range. 
 
The pooled effect is 1.097, which means that the addition of caffeine increases the chance of relief by 
about 10%.  This is a modest increase but statistically significant (p< 0.001). 
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Click [Both models] 

The program displays results for both the fixed-effect and the random-effects analysis. 

 

Under the fixed-effect model the pooled effect size is 1.097, while under the random-effects model the 
pooled effect size is 1.111. While the two models yield very similar results, the random-effects model is 
a better fit for the way the studies were sampled, and therefore that is the model we will use in the 
analysis. 

• The fixed-effect model would be appropriate if all the studies were virtual replicates of each 
other, which is not the case here.  The dose varied, the analgesic varied, the patients varied. 
 

• The random-effects model would be appropriate if the studies vary in ways that may impact the 
effect size (such as those mentioned immediately above).  Therefore, we will use the random-
effects model. 
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• Click Random on the tab at the bottom 

The plot now displays the random-effects analysis alone. 

 

 

A quick view of the plot suggests the following 

 Most of the studies suggest an advantage for caffeine 
 The observed effects are pretty consistent, with three exceptions. 
 The summary effect is 1.111 with a CI of 1.064 to 1.161.  Thus, the mean effect is small (only 

about a 10% increase in response as compared with the control). 
 The summary effect has a Z-value 4.721 a p-value of < 0.001.  Thus we can reject the null 

hypotheses that the true risk ratio is 1.0. 
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Click [Next table]  

 

 

 

Figure 1 

The statistics at the left duplicate those we saw on the prior screen. 

 Under the random-effects model the risk ratio is 1.111 with a 95% confidence interval of 1.064 
to 1.161.  The test of the null (that the true risk ratio is 1.0) yields a Z-value of 4.721 and a 
corresponding p-value of < 0.001. 

 The statistics at the upper right relate to the dispersion of effect sizes across studies. 
 The Q-value is 27.7234 with df=24 and p=0.271.  Q reflects the distance of each study from the 

mean effect (weighted, squared, and summed over all studies).  Q is always computed using FE 
weights (which is the reason it is displayed on the “Fixed” row, but applies to both FE and RE 
analyses. 

 If all studies actually shared the same true effect size, the expected value of Q would be equal to 
df (which is 24).  Here, Q is greater than that value, and so there is some evidence of variance in 
true effects.  However, this excess variance falls within the range that could be attributed to 
random sampling error in effect sizes (not statistically significant). 

 While the heterogeneity is not statistically significant, we will still use the random-effects model, 
since this matches the sampling frame for the studies. 

 T2 is the estimate of the between-study variance in true effects.  This estimate is 0.001. T is the 
estimate of the between-study standard deviation in true effects.  This estimate is 0.037. These 
value are both in log units. 

 I2 reflects the proportion of true variance to observed variance.  This is 13.46, which tells us that 
only about 13% of the observed variance in effects is real.  Put another way, if we were looking 
at a plot of the true effects rather than the observed effects, the variance in effects would be 
decreased by (1 minus .13) some 87%. 

 Click [Next table] to return to this screen 

  

Click here 
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Under the random-effects model the risk ratio is 1.111 with a 95% confidence interval of 1.064 to 1.161.  
This tells is that the mean true effect probably falls in the range of 1.064 to 1.161.  However, since the 
true risk ratio varies from study to study, we might also want to know how widely the true risk ratios 
vary from the mean.  This is the role of the prediction interval.  We can use the spreadsheet [Prediction 
intervals] as follows. 
 
Since we have select Risk ratio as the effect size, some of the statistics in this table are presented in risk 
ratio units.  To compute the prediction interval we’ll need to see statistics in log units. 
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• Open the spreadsheet [Prediction Intervals.xls] 
• Select the tab for [Ratios] 
• In CMA select Log risk ratio as the index 
• Select Format > Increase decimals 
• Copy the A|B|C|D values as shown from CMA to Excel 

 

Figure 2 

 

The confidence interval is 1.064 to 1.161 (we read this from Figure 1 which shows the risk ratios rather 
than the log values). The prediction interval (from Excel) is 1.015 to 1.216. 

The true risk ratio varies from study to study.  The mean risk ratio probably falls in the range of 1.064 to 
1.161.  The true effect size for any single study will usually fall in the range of 1.015 to 1.216. 

A B D 
C 

© www.Meta-Analysis.com                               Caffeine by subgroups                                                  —  24 —    

 

http://www.meta-analysis.com/


 
In 95% of all possible meta-analyses, the true mean will fall in the range indicated by the CI.  In 95% of all 
meta-analyses, 95% of all studies will fall inside the range indicated by the PI.  This assumes that the true 
effect sizes are normally distributed.  
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To this point we’ve established that caffeine is effective, but the effect is rather small.  However, we 
know that the dose of caffeine varied among studies. We’re going to group by dose (low, moderate, or 
high) and see if the effect size was related to dose. 

When we’re dividing the studies into subgroups, the between-studies variance (T2) must be computed 
within subgroups.  However, we have two options.  We can then pool the separate estimates, and use 
the pooled value for all subgroups.  Or, we can use a separate estimate for each subgroup. 

Our plan is to pool the estimates.  To select that option 

Click Computational options > Mixed and random effects options 

 

 

The program displays this wizard 

• At the top select the first option, to “Assume a common among-study variance” 
• At the bottom select the first option, to “Combine subgroups using a fixed-effect model” 
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Now, we can tell the program to run the analysis by subgroups. 

Click Computational options > Group by 

 

 

• Select Dose 
• Check the two boxes 
• Click Ok 
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The screen should look like this 

 

For the low, medium, and high-dose studies the mean risk ratio is 1.110, 1.114, and 1.120, respectively.  
Therefore, there’s no evidence that the impact varies by dose.   
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Click the “Show individual studies” button.  This will hide all of the individual studies and display the 
summary effects only as shown here. 

 

Right-click on the forest plot and change the scale to 0.50 to 2 

 

With the pooled effects clarified in this way, we can see clearly that the summary effect size is virtually 
identical in all three dose groups. 

Note that the effect is statistically significant for the medium and high doses, but not for the low dose.  
However, it would be a serious mistake to conclude that the effect varies by dose.  Clearly, the effect is 
essentially identical for all three doses.  What distinguishes the low dose group from the others is not 
that the effect is smaller, but only that the estimate of the effect size is less precise.  (And in this 
example that’s solely because there are only four studies in the low-dose group). 

It is fair to say that we have evidence of the effect in two groups only.  It is not correct to say that the 
effect in the low dose group is smaller unless the test that compares the effects shows a statistically 
significant effect of dose (which it will not in this case). 

Toggle the “All studies button” to display the studies again. 
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Given what we’ve seen, it’s clear that there the test to compare doses will not be statistically significant, 
but we’ll proceed to show the test. 

Click Next table 

 

This screen displays two sets of statistics 

The table labeled “Fixed-effect analysis” uses fixed-effect weights within subgroups.  The table labeled 
“Mixed-effects analysis” uses random-effects weights within subgroups.  This is the table we will use. 

As we saw on the prior screen, the risk ratio within the three subgroups is 1.110, 1.114, and 1.117.  The 
effect is not statistically significant in the low-dose group (p=0.216) but is statistically significant in the 
other two (p< 0.001, p=0.038).  However, this does not suggest that the effect is smaller in the first 
group (clearly, the effect size in the sample is virtually identical in all three groups). 

To test the hypothesis that the effect size varies by dose we look to the line labeled “Total between”.  
The Q-value is 0.010 with 2 df, and the corresponding p-value is 0.995.   
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Click Next table to return to this screen. 

Re-set the scale to 0.01 to 100 
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Above, we ran an analysis to see if the effect size varied by dose. Now, we’ll run an analysis to see if the 
effect size varies by the type of analgesic. 

Click Computational options > Group by > Analgesic 

 

We see that there are a number of studies that used Ibuprofen or Paracetamol, but only a few that are 
classified as “Unknown”.  Let’s limit the analysis to those the first two groups. 
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Click Computational options > Select by > Analgesic 

• Select Ibupfrofen and Paracetamol 
• De-select “Unknown” 
• Click Ok 
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The screen should look like this 

 

Hide the individual studies and change the scale 

 

For studies that used ibuprofen, caffeine increased the response rate by 29%. For studies that used 
Paracetemol, caffeine increased the response rate by 11%.  Thus, the difference in this sample is 
substantial.   

However, there’s a lot of overlap in the confidence intervals and it’s not clear whether or not this 
difference is statistically significant.  To compare the two effects, click Next table. 
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As before, we’re working with the section labeled “Mixed effects analysis” and the relevant line is the 
one labelled “Total between”.  The Q-value is 3.819 with 1 df, and the corresponding p-value is 0.051.   
 
People have different ways of reacting to a p-value this close to 0.05.  I would conclude that caffeine 
does have more of an impact for patients being treated with ibuprofen than for patients being treated 
with paracetamol. 
 
Perhaps more to the point, this suggests that the overall effect size reported earlier (that caffeine 
increases the response rate by 11%) is really not that relevant to clinical practice.  Rather, the utility of 
caffeine depends on the analgesic.  For patients being treated with paracetamol, caffeine had a small 
impact.  For patients being treated with ibuprofen, caffeine had a larger impact. 
 
As always, the difference between groups is observational, not causal.  It’s possible that caffeine works 
better with ibuprofen.  But it’s also possible that the studies which used ibuprofen differed in some ways 
from the studies that used paracetamol and that it’s this factor that was responsible (at least in part) for 
the difference in effect sizes. 

It’s worth noting that the higher response rate for the ibuprofen studies seems to be driven (at least in 
part) by three studies.  If there was something unique about these studies that led to the higher 
response rate, then the difference between subgroups might be due to this factor, and not to the 
analgesic. 

This is always a concern when we compare subgroups.  While the allocation to caffeine vs control is 
based on random assignment, the “allocation” to one subgroup vs. another is observational.  While we 
are referring to the subgroups as “Ibuprofen” vs. “Paracetamol”, it’s possible that they should be called 
“Ibuprofen young sample” vs. “Paracetamol older sample”, and that caffeine works better with younger 
patients.  (The age part of this example is purely hypothetical). 
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The studies were also coded for the nature of the pain, and we want to see if the effect size varies by 
this factor. 

First, we need to remove the current filter.   

Click Computation options > Select by and tick all the options 
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Group by Pain type 

Select Computational options > Group by > Pain type 

 

 

It seems that we have only one study where the pain type is Dysmenorrheea, and so let’s remove that 
from this analysis 
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Click Computational options > Select by > Pain type 

Select Headache and Post-op 

 

Group by Pain type 
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Hide the individual studies and expand the scale 

 

The effect size seems to be almost identical for the two types of pain 

Click Next table 

 

The risk ratio is 1.104 for Headache, and 1.127 for Post-op.  The line total-between shows the Q-value 
that compares these two effects sizes.  The Q-value is 0.173 with 1 df and p=0.677. 

There’s no evidence that the impact of caffeine differs by pain type. 
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Above, we found evidence that caffeine had a stronger effect for patients on ibuprofen than for patients 
on parecetamol.   

It would be helpful to know if this relationship could be explained by a confound with type of pain, or 
with dose.  For example, if the patients taking ibuprofen were more likely to have had a higher dose of 
caffeine, this could explain the larger effect for these patients.  In the present case this seems unlikely, 
since we found essentially no effect for dose.  However, for completeness we will proceed with a meta-
regression.   

As before, we will limit the analysis to studies that used ibuprofen or paracetamol.  We will do this for all 
the regressions, to ensure that all are based on the same set of studies. 
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To select only the desired studies 

On the main analysis screen (before proceeding to the regression) 

• Click Computational options > Select by 
• Select Analgesic 
• Select Ibuprofen and Paracetamol 
• De-select Unknown 
• Click Ok 
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Click Analyses > Meta-regression 2 

 

First, we run the regression using only Analgesic as the covariate.  The Q-value for the analgesic is 
3.8193 with p= 0.0507, precisely the same values we saw in the subgroups analysis. 
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Now, we add Dose and Pain Type as covariates in addition to the analgesic.  With these covariates in the 
model, the line for “Analgesic” tests the impact of this covariate controlling for the other covariates.  
The p-value is now 0.0451.  As expected, since the other covariates had no relation to effect size, 
including them in the model made no real difference.  The p-value for analgesic is essentially unchanged. 

This tells us that the relationship between analgesic type and effect size is not due to a confound with 
these other two covariates.  Unfortunately, it’s still possible that it’s due to a confound with some other 
(unknown) covariates (possibly some unique aspect of the three outlier studies in the ibuprofen group). 
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Summary 

This analysis includes 25 studies where patients were randomized to receive either analgesic alone or 
analgesic plus caffeine.  Outcome was the proportion of patients who reported a “good” level of pain 
relief. The effect size was the risk ratio. 

Does caffeine affect the likelihood of a good response? 

The mean risk ratio is 1.111, which means that caffeine increased the likelihood of a good response by 
about 11%.   

These studies were sampled from a universe of possible studies defined by certain inclusion/exclusion 
rules as outlined in the full paper. The confidence interval for the risk ratio is 1.064 to 1.161, which tells 
us that the mean risk ratio in the universe of studies could fall anywhere in this range.  This range does 
not include a risk ratio of 1.0, which tells us that the mean risk ratio is probably not 1.0.   

Similarly, the Z-value for testing the null hypothesis (that the mean risk ratio is 1.0) is 4.721, with a 
corresponding p-value is < 0.001.  We can reject the null hypothesis that caffeine has no effect on 
response, and conclude that the risk of death is lower in the high-dose group.   

Does the effect size vary across studies? 

The observed effect size varies somewhat from study to study, but a certain amount of variation is 
expected due to sampling error.  We need to determine if the observed variation falls within the range 
that can be attributed to sampling error (in which case there is no evidence of variation in true effects), 
or if it exceeds that range. 

The Q-statistic provides a test of the null hypothesis that all studies in the analysis share a common 
effect size.  If all studies shared the same effect size, the expected value of Q would be equal to the 
degrees of freedom (the number of studies minus 1).   

The Q-value is 27.73 with 24 degrees of freedom and a p-value of 0.271.  Since the observed variance 
falls within the range that can be attributed to sampling error, we cannot reject the null that the true 
effect size is the same in all studies.  At the same time, since the observed variance does exceed the 
expected value, we can report statistics for the estimate of dispersion in true effects.   

The I2 statistic tells us what proportion of the observed variance reflects differences in true effect sizes 
rather than sampling error. Here, I2 is 13.642%. 

T2 is the variance of true effect sizes (in log units).  Here, T2 is 0.001. T is the standard deviation of true 
effects (in log units).  Here, T is 0.037. 

Does the effect size vary by subgroup? 

While the mean effect size across all studies is modest (a risk ratio of 1.111), it’s possible that the mean 
risk ratio varies by subgroup.    
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We used subgroup analyses to compare the effect size in studies that employed a low dose, moderate 
dose, or high dose of caffeine.  The mean risk ratio in these three groups was 1.11, 1.11, and 1.12, 
respectively.  The Q-value for the difference is 0.010with 2 df and p = 0.995. Thus, there was no 
evidence that the risk ratio varied as a function of caffeine dose. 
 
We used subgroup analyses to compare the effect size in studies where patients were being treated for 
headache vs. studies were being treated for post-surgical pain. The mean risk ratio in these two groups 
was 1.10, 1.13, respectively.  The Q-value for the difference is 0.173 with 1 df and p = 0.877.  Thus, there 
was no evidence that the risk ratio varied as a function of the pain type. 
 
We used subgroup analyses to compare the effect size in studies where the analgesic was Ibuprofen vs. 
studies where the analgesic was Paracetamol. The mean risk ratio in these two groups was 1.29, 1.11, 
respectively.  The Q-value for the difference is 3.819 with 1 df and p = 0.051.  Thus, there is evidence 
that the caffeine had more of an impact in the Ibuprofen studies than it did in the Paracetamol studies.   
 
We used regression to see if this relationship could be explained by a confound with other moderators.  
The relationship between effect size and drug type remained even after we controlled for caffeine dose 
and for pain-type.  Nevertheless, we cannot rule out the possibility that the selection of drug was 
related to other factors, and that these factors were responsible for the fact that caffeine was more 
effective in one subgroup than the other. 
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